odd error with sqlite3 adaptor

Any idea what would cause this?

icps = Icp.find(:all)

ActiveRecord::StatementInvalid: SQLite3::SQLException: unsupported file
format:
SELECT * FROM icps
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/connection_adapters/abstract_adapter.rb:120:in `log'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/connection_adapters/sqlite_adapter.rb:137:in `execute'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/connection_adapters/sqlite_adapter.rb:329:in `catch_schema_changes'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/connection_adapters/sqlite_adapter.rb:137:in `execute'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/connection_adapters/sqlite_adapter.rb:157:in `select_all'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/base.rb:390:in `find_by_sql'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/base.rb:924:in `find_every'
        from
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-1.14.4/lib/active_recor
d/base.rb:381:in `find'
        from (irb):2

Thanks,
Mike

does the sqlite3 command line successfully open the db?

-faisal

Faisal N Jawdat wrote:

does the sqlite3 command line successfully open the db?

Yes, it does. No problems at all in querying the schemas, selecting
rows, etc.

I found the issue.

I created the db with sqlite3 3.3.8, and the gem was built against
3.3.10. Apparently sqlite's backwards compatability isn't what it
claims to be.

Mike