newbie installation issue (zlib)

I'm installing on a linux system (suse) using the instructions at
hivelogic for installing on Tiger.
So far so good, as far as ruby & rubyGems is concerned.

When I get to Rails installation:
  sudo gem install rails --include-dependcies

I get:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require': no such file to load -- zlib (LoadError)
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/package.rb:9
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/builder.rb:7
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:93:in
`manage_gems'
        from /usr/local/bin/gem:10

As I don't know the language and how it expresses library dependencies
I don't know what to do with this.

I have libz installed in /lib and also in /usr/local/lib.

thanks !!
minka

Yes I needed zlib.
I had reinstall ruby afterwards.
(on suse zlib is zlib-devel)
there is a good installation write-up for suse:
http://developer.novell.com/wiki/index.php/Configuring_Ruby_Rails_for_Apache_on_SUSE_Linux_Enterprise_Server