Nested map.resources no longer working with Rails 2 RC

I have the following routes setup:

map.resources :designs, :has_many => :notes
  map.resources :designs do |designs|
    designs.resources :notes, :has_many => :comments
    designs.resources :notes do |notes|
      notes.resources :comments
    end
end

And this view:

<td><%= h design.title %></td>
<td><% @design = design %><%= image_tag url_for_file_column("design",
"design_file", "thumb") %></td>
<td><%= link_to 'show', design_path(design) %></td>
<td><%= link_to "#{design.notes_count} notes", notes_path(design) %></

Is giving me the error: undefined method `notes_path' for, it used to
work (we were on 1.2.2 but I've also tried 1.2.6) but it doesn't any
more (I've tried RC1 - 1.99.0 & RC2 1.99.1).

I've not seen anything in the RC documentation that gives me a clue as
to why this isn't working anymore and I'm a bit stuck, so any advice
would be really helpful.

Note I've also tried changing the routes to the following, with no
luck:

map.resources :designs do |designs|
    designs.resources :notes do |notes|
      notes.resources :comments
    end
end

Ah-ha I have it, I needed design_notes_path, I just ran the rake
routes script and that gave me all I needed to know, I can't believe I
spent so long looking for this answer when it was sitting right in
front of me in the preview release notes. Sometimes you just can't see
what's in front of your face.