n00b can't run script/generate ugh

Just got ruby/gems/rails installed (OS 10.3), I've been able to login
to the http://localhost:3000 and see that I am at least doing
something right...

When I try to run script/generate I get:

Grey-Box:~/sites/test shenry$ script/generate
Rails requires RubyGems >= 0.9.4. Please install RubyGems and try
again: http://rubygems.rubyforge.org

but I can confirm that my current gems version is 0.9.5... any help
would be greatly appreciated by this n00b. Thanks.

-sh

Figured out the problem ... I need to run $ . ~/.bash_login before
these commands or it thinks I have an old version of gems.

My .bash_login file reads:

export PATH="/usr/local/bin:/usr/local/sbin:/usr/local/mysql/bin:
$PATH"

How do I make Terminal run this script on login?

thanks for any help