missing sourcefile (no such file to load)-- squlite3 error

Ryan Bigg wrote:

Rails 2.0.2 uses sqlite3 by default. Either you:

1. Install sqlite and install the sqlite-ruby gem.
2. Specify rails -d mysql <project name> when creating your projects.
3. Manually change it in config/database.yml

Hello, my english is too bad, but i hope you understand me.

I continued his instructions, and everything work ok, but then me the
following mistake appears:

Routing Error

No route matches "/Mi_Prueba" with {:method=>:get}

I created another application from the beginning and always the same
thing goes out

Try rebooting your server first if you made changes to your
database.yml file

Try 'gem install sqlite3-ruby'

Niki Van cleemput wrote:

Try 'gem install sqlite3-ruby

I'm assuming you're using Windows as your development machine, so before
doing the suggestion above, you must:

1. Download the precompiled sqlite3 binaries for Windows at
http://www.sqlite.org/download.html.
At the time of writing, these are sqlite-3_5_9.zip and
sqlitedll-3_5_9.zip.

2. Extract the files (you'll have 3 files: sqlite3.exe, sqlite3.dll, and
sqlite3.def) and place it in your ruby's bin directory (C:\ruby\bin).

3. Go to your command line and navigate to your bin directory, and type
"gem install sqlite3-ruby"... press Enter. Wait for the files to be
downloaded to your system.

4. You should now have sqlite3 working.

Adam Akhtar-2 wrote:

Niki Van cleemput wrote:

Try 'gem install sqlite3-ruby

I'm assuming you're using Windows as your development machine, so before
doing the suggestion above, you must:

1. Download the precompiled sqlite3 binaries for Windows at
http://www.sqlite.org/download.html.
At the time of writing, these are sqlite-3_5_9.zip and
sqlitedll-3_5_9.zip.

2. Extract the files (you'll have 3 files: sqlite3.exe, sqlite3.dll, and
sqlite3.def) and place it in your ruby's bin directory (C:\ruby\bin).

3. Go to your command line and navigate to your bin directory, and type
"gem install sqlite3-ruby"... press Enter. Wait for the files to be
downloaded to your system.

4. You should now have sqlite3 working.
--
Posted via http://www.ruby-forum.com/.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups
"Ruby on Rails: Talk" group.
To post to this group, send email to rubyonrails-talk@googlegroups.com
To unsubscribe from this group, send email to
rubyonrails-talk-unsubscribe@googlegroups.com
For more options, visit this group at
http://groups.google.com/group/rubyonrails-talk?hl=en
-~----------~----~----~----~------~----~------~--~---

Adam thank you :jumping: for this info it has taken me two days to
eventually solve my problem: FAILSAFE 500 internal server error no such file
to load - sqlite3.
best regards :handshake: