Minimum version of rubygems required?

What is the general opinion on the minimum required version of rubygems to
run Rails? I'm running 0.8.11, and I've not yet had any problems running
the test suites or Rails itself. The patch currently attached to
http://dev.rubyonrails.org/ticket/6703, will, if applied, mean that the
minimum version of rubygems required to run the test suite will be 0.9.0.

Is this a reasonable requirement, or should the patch be modified to load
mocha the same way as all the other test suites, which works fine with my
ancient version of rubygems?

- Matt

If the suite can work without the “gem” command, then why shouldn’t it? As you have said [*], other Mocha detection scripts in the framework don’t need it. Mocha gem has the “lib/mocha.rb” file, so it can be easily require’d. “soap4r” doesn’t have "
soap4r.rb", on the other hand, so you must use the gem command:

gem ‘soap4r’

+1 for not using the gem command when a simple require is enough.

[*]
http://dev.rubyonrails.org/ticket/6703#comment:14

What is the general opinion on the minimum required version of rubygems to
run Rails? I'm running 0.8.11, and I've not yet had any problems running
the test suites or Rails itself.

Wasn't there a security issue with old rubygems?

http://nvd.nist.gov/nvd.cfm?cvename=CVE-2007-0469

Argh! … 0.9.0 also? I guess I’ll have to uninstall the deb package and install latest rubygems manually.

Thanks for the notice