Mac OSX Leopard + rails3 problems

I Just installed ruby 1.8.7, rubygems 1.8.3 i think and Rails 3.0.7 and
I get this messages everywhere

tomas$ rails s
NOTE: Gem::Specification#has_rdoc= is deprecated with no replacement. It
will be removed on or after 2011-10-01.
Gem::Specification#has_rdoc= called from
/opt/local/lib/ruby/gems/1.8/specifications/activesupport-3.0.7.gemspec:13.
NOTE: Gem::Specification#has_rdoc= is deprecated with no replacement. It
will be removed on or after 2011-10-01.
Gem::Specification#has_rdoc= called from
/opt/local/lib/ruby/gems/1.8/specifications/builder-2.1.2.gemspec:16.
NOTE: Gem::Specification#has_rdoc= is deprecated with no replacement. It
will be removed on or after 2011-10-01.
Gem::Specification#has_rdoc= called from
/opt/local/lib/ruby/gems/1.8/specifications/activesupport-3.0.7.gemspec:13.
NOTE: Gem::Specification#has_rdoc= is deprecated with no replacement. It
will be removed on or after 2011-10-01.
Gem::Specification#has_rdoc= called from
/opt/local/lib/ruby/gems/1.8/specifications/builder-2.1.2.gemspec:16.
NOTE: Gem::Specification#has_rdoc= is deprecated with no replacement. It
will be removed on or after 2011-10-01.
Gem::Specification#has_rdoc= called from
/opt/local/lib/ruby/gems/1.8/specifications/activesupport-3.0.7.gemspec:13.
NOTE: Gem::Specification#has_rdoc= is deprecated with no replacement. It
will be removed on or after 2011-10-01.
Gem::Specification#has_rdoc= called from
/opt/local/lib/ruby/gems/1.8/specifications/builder-2.1.2.gemspec:16.
=> Booting WEBrick
=> Rails 3.0.7 application starting in development on
http://0.0.0.0:3000
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2011-05-21 16:40:58] INFO WEBrick 1.3.1
[2011-05-21 16:40:58] INFO ruby 1.8.7 (2011-02-18) [i686-darwin9]
[2011-05-21 16:40:58] INFO WEBrick::HTTPServer#start: pid=351 port=3000

it's self explanatory .. or not?

if you want to get rid off this messages, downgrade slightly your rubygems

has_rdoc will be removed from rubygems, and as this is still present in the source gemspec of given packages, you get this message

tom

The problem was self-explanatory, but (for me, at least) the solution wasn't.

Run:
  rvm rubygems current

Which of course means you have to set up rvm first, if you haven't.

I ran: gem pristine --all --no-extensions
and now ok.

thanks you guy rubygems 1.8.2 runs just perfect

sudo gem update --system 1.8.2