Launching server from Aptana....

Hi Rails group.... (new to Rails/ruby, so please excuse if this is dumb

I have installed Rails, and done some small testing. Had the server up
and running, and I did get the 'default' page.

Then I installed the 'Aptana Studio RadRails (version RadRails when I launched the Aptana->Rails perspective, a
lots of ruby/rails stuff got installed.

When I create a Rails project (inside Aptana), and try to start the
server (both Webrick and the Mongrel), I get this message:

Cannot find gem for Rails ~>
    Install the missing gem with 'gem install -v=1.2.4 rails', or
    change environment.rb to define RAILS_GEM_VERSION with your desired


If I run the server in the terminal (go to the project, run
script/server) I got the same message. But after a lot of trying,
running this command 'gem install -v=1.2.4 rails' it installed a lot of
stuff, and it now works from the terminal. But I get the same error from
the Aptana tool. I have tried to reboot. I'm running Ubuntu 7.10. Have
tried to build new project, after the install, same result.

If I run the gem install again, it just says 'Successfully installed
', so this version should be installed....

What should I do ??

Regards Jørn

open the environment.rb file and edit the line that has rails version.

Actually that is a pretty brief answer.
in the cmd window type rails -v
you probably will see 2.0.2

For some reason, it appears that Aptana thinks you are running rails
version1.2.4 which if it existed, only lasted like days until it was
replaced due to a bug and Rails 1.2.5 was released.

Open Apatana and look in the vendor directory and see if there is a
rails directory. This is where Rail would be installed if rails was
frozen to version 1.2.4

if so, type rails:unfreeze (that might me wrong, but it is close.
Google it)
or just delete the rails directory in project/vendor/rails

Update Apatana?

hope this helps