Also, am I the only one that sees no point in wrapping 'state' as a
string in itself? I mean it's a string anyway. You could achieve the
same with just <%= state %>, making for more readable code -- is there
an advantage I am not aware of in using the <%= "#{state}" %> way?
This should generate a <select> tag for the instance variable :order
that affects the ship_to_state attribute. It should contain a
<select> tag for each state with a value and display element exactly
the same: The name of the state.
Also, am I the only one that sees no point in wrapping 'state' as a
string in itself? I mean it's a string anyway. You could achieve the
same with just <%= state %>, making for more readable code -- is there
an advantage I am not aware of in using the <%= "#{state}" %> way?
No, you're not. I thought the same thing but was at work and couldn't
linger over the question too long. I don't see that there is any
additional benefit.