issues with mysql on windows

im getting my laptop ready for training class and having issues with
mysql
i am able to get a project running using sqlite, but not mysql

instructions i followed for installation are here:
http://wiki.rubyonrails.org/getting-started/installation/windows

i created a project and quick scaffold successfully

rails test_mysql -d mysql
cd test_mysql
ruby script/generate scaffold location name:string

i then tried to create db but received error
rake db:create
(in C:/Documents and Settings/dan/sites/test_mysql)
c:/ruby/lib/ruby/gems/1.8/gems/activerecord-2.3.4/lib/active_record/
connection_a
dapters/mysql_adapter.rb:197: [BUG] Segmentation fault
ruby 1.8.6 (2007-09-24) [i386-mswin32]

modified database.yml to include root users password and ran rake
again
rake db:create
test_mysql_development already exists

so i tried to migrate...
rake db:migrate
(in C:/Documents and Settings/dan/sites/test_mysql)
rake aborted!
Mysql::Error: query: not connected: CREATE TABLE `schema_migrations`
(`version`
varchar(255) NOT NULL) ENGINE=InnoDB

why is mysql being so difficult?

ruby 1.8.6
mysql 5.1.41

*** LOCAL GEMS ***

actionmailer (2.3.4)
actionpack (2.3.4)
activerecord (2.3.4)
activeresource (2.3.4)
activesupport (2.3.4)
fxri (0.3.6)
fxruby (1.6.12)
hpricot (0.6)
log4r (1.0.5)
mysql (2.8.1)
rack (1.0.1)
rails (2.3.4)
rake (0.8.7, 0.7.3)
sources (0.0.1)
sqlite3-ruby (1.2.3)
win32-api (1.0.4)
win32-clipboard (0.4.3)
win32-dir (0.3.2)
win32-eventlog (0.4.6)
win32-file (0.5.4)
win32-file-stat (1.2.7)
win32-process (0.5.3)
win32-sapi (0.1.4)
win32-sound (0.4.1)
windows-api (0.2.0)
windows-pr (0.7.2)

Hi dan,

I have a recent experience trying to update everything to the last
version here.

Rails 2.3.4, MySQL 5.1 and others...

After a few tests it became clear MySQL 5.1 doesn't work well with
Rails (don't ask me why).

My solution: Uninstall MySQL 5.1 and re-install 5.0.

Everything works fine now.

Regards.

well what do you know...it works!

uninstalled 5.1, installed 5.0.88...rake db:create, rake
db:migrate...awesome

thanks

(does this apply to mac also?)

Nope, at least with leopard (can't confirm snow-leopard) MacOSX 10.5.8
running Rails 2.3.4 with Ruby 1.8.7 or 1.9.1 and Rails 3.0.pre with
Ruby 1.9.2.

mysql --version =>
mysql Ver 14.14 Distrib 5.1.39, for apple-darwin9.5.0 (powerpc) using
readline 5.1

Rick,

mysql --version =>
mysql Ver 14.14 Distrib 5.1.39, for apple-darwin9.5.0 (powerpc) using
readline 5.1

You are using 5.1.39...

Need to test with 5.0.xx...

Regards.