issues with multiple versions of rails installed, pls advise

I've got multiple versions of rails currently installed, 1.2.6 and 2.1.
I need 1.2.6 as I have an active app that is based on 1.2.6 and am not
in a position to move it to 2.1. I know about the _version_ trick when
generating a new project. My problem is when running 'script/generate
migration ...' within the 1.2.6 project. I get a message stating that I
need to update my boot.rb and my migration file is never generated.
removing the 2.1 gem fixes the problem, but I'd like to keep it for
additional projects.

Anyone got any ideas on how to get around this?

Chris

Set the gem version in environment.rb or freeze rails into the project.

Fred