Issue with Rails application on SSL

Hi,
  I am facing an abnormal issue with my Ruby on Rails application. The
application is running with apache, with fcgi module.
  When I turned on SSL connection on apache, the application kind of
started working strangely.
  Seems like when SSL encryption is on, rails action is executed
thrice (3 times), and the 1st time all parameters are passed properly
but last 2 times no parameter is passed or they are blank.

Please can anyone help me solving this or giving any pointer to the
solution. Thanks in advance.

The application versions are as follows:
      Rails - 1.2.3
      Ruby - 1.8.7
      Gem - 1.8.10

ERROR Seen:

ActionController::RoutingError (no route found to match "/blank.htm"
with {:method=>:get}):
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/
action_controller/routing.rb:1292:in `recognize_path'
    /usr/lib/ruby/gems/1.8/gems/actionpack-1.13.3/lib/
action_controller/routing.rb:1282:in `recognize'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/dispatcher.rb:40:in
`dispatch'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:168:in
`process_request'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:143:in
`process_each_request!'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:109:in
`with_signal_handler'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:142:in
`process_each_request!'
    /usr/lib/ruby/1.8/fcgi.rb:612:in `each_cgi'
    /usr/lib/ruby/1.8/fcgi.rb:609:in `each'
    /usr/lib/ruby/1.8/fcgi.rb:609:in `each_cgi'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:141:in
`process_each_request!'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:55:in
`process!'
    /usr/lib/ruby/gems/1.8/gems/rails-1.2.3/lib/fcgi_handler.rb:25:in
`process!'
    /home/PST/public/dispatch.fcgi:24