Issue with Memcache session store setup..Rails 2.1

Hello All-

I've been using the memcache session store sucessfully since rails
2.0, but after starting a new app with v 2.1 I'm getting the following
error at each page request:

loading from application: home_controller
loading from application: home_helper
/!\ FAILSAFE /!\ Tue Jun 10 18:46:10 -0500 2008
  Status: 500 Internal Server Error
  session_id
'BAh7CSIRaW50ZXJhY3Rpb25zexMiEzIzNDU2Mjc4MzIxNTIwbzoUVGVhbUlu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--
e3a5cbc6c993f453fd47bff468c35b0dc1a979a3' is invalid
    /home/mwkohout/svnWorkingCopy/ictr/mentor/trunk/mentor/mentor/
vendor/rails/actionpack/lib/action_controller/session/
mem_cache_store.rb:54:in `initialize'

This is happening with both 2.1 and edge. Any pointers? Any updated
howtos out there?

thanks
Mike Kohout

FYI, my memcache settings started as this

development:
memcache_options = {
   :compression => false,
   :debug => false,
   :namespace => "app-dcru-#{RAILS_ENV}",
   :readonly => false,
   :urlencode => false
}
memcache_servers = [ 'localhost:11211' ]

config.action_controller.fragment_cache_store = :mem_cache_store,
memcache_servers, memcache_options

cache_params = *([memcache_servers, memcache_options].flatten)
CACHE = MemCache.new *cache_params
ActionController::CgiRequest::DEFAULT_SESSION_OPTIONS.merge!({ 'cache'
=> CACHE })
config.action_controller.session_store = :mem_cache_store

then I whittled them down to this:
config.action_controller.session_store = :mem_cache_store

neither work with >= rails 2.1

Hi,
I have the same problem. try to comment these lines in your
config/environment.rb:
config.action_controller.session = {
   :session_key => '_app_session',
   :secret => 'a_long_hash_key'
}

That's work for me !
And I used rails v 2.1