Issue using bundler

I run bundle install, or bundle update, and it fails. I'm using RVM, so
if I switch to Ruby 1.9.2, this works fine, but using Ruby 1.8.7 it
fails. Any idea?

jeremy-woertinks-imac:winovations jeremywoertink$ bundle update
Fetching source index for http://rubygems.org/
Using rake (0.8.7)
Using RedCloth (4.2.3)
Using abstract (1.0.0)
Installing activesupport (3.0.1)
/Library/Ruby/Site/1.8/rubygems/installer.rb:164:in `install':
activesupport requires Ruby version >= 1.8.7. (Gem::InstallError)
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/source.rb:95:in
`install'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/installer.rb:55:in
`run'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in
`each'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/spec_set.rb:12:in
`each'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/installer.rb:44:in
`run'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/installer.rb:8:in
`install'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/cli.rb:271:in
`update'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/vendor/thor/task.rb:22:in
`send'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/vendor/thor/task.rb:22:in
`run'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/vendor/thor/invocation.rb:118:in
`invoke_task'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/vendor/thor.rb:246:in
`dispatch'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/lib/bundler/vendor/thor/base.rb:389:in
`start'
  from
/Users/jeremywoertink/.rvm/gems/ruby-1.8.7-p302/gems/bundler-1.0.7/bin/bundle:13
  from /usr/bin/bundle:19:in `load'
  from /usr/bin/bundle:19
jeremy-woertinks-imac:winovations jeremywoertink$ bundle -v
Bundler version 1.0.7
jeremy-woertinks-imac:winovations jeremywoertink$ ruby -v
ruby 1.8.7 (2010-08-16 patchlevel 302) [i686-darwin9.8.0]
jeremy-woertinks-imac:winovations jeremywoertink$ gem -v
1.3.7
jeremy-woertinks-imac:winovations jeremywoertink$ rvm -v

rvm 0.1.46 by Wayne E. Seguin (wayneeseguin@gmail.com)
[http://rvm.beginrescueend.com/]

I run bundle install, or bundle update, and it fails. I'm using RVM, so
if I switch to Ruby 1.9.2, this works fine, but using Ruby 1.8.7 it
fails. Any idea?

jeremy-woertinks-imac:winovations jeremywoertink$ bundle update
Fetching source index for http://rubygems.org/
Using rake (0.8.7)
Using RedCloth (4.2.3)
Using abstract (1.0.0)
Installing activesupport (3.0.1)

Does the above mean you are trying to use rails 3.0.1 with ruby 1.8.7?
If so there is the problem.

/Library/Ruby/Site/1.8/rubygems/installer.rb:164:in `install':
activesupport requires Ruby version >= 1.8.7. (Gem::InstallError)

That says you need a later ruby for activesupport 3 I think

Colin

Does the above mean you are trying to use rails 3.0.1 with ruby 1.8.7?
If so there is the problem.

/Library/Ruby/Site/1.8/rubygems/installer.rb:164:in `install':
activesupport requires Ruby version >= 1.8.7. (Gem::InstallError)

That says you need a later ruby for activesupport 3 I think

Colin

Yes, I'm trying to use Rails 3.0.1 with Ruby 1.8.7, but I get the same
error if I switch to 3.0.0. Anyway, Rails 3.0 works with Ruby 1.8.7 (or
at least it should)...

Does the above mean you are trying to use rails 3.0.1 with ruby 1.8.7?
If so there is the problem.

/Library/Ruby/Site/1.8/rubygems/installer.rb:164:in `install':
activesupport requires Ruby version >= 1.8.7. (Gem::InstallError)

That says you need a later ruby for activesupport 3 I think

Colin

Yes, I'm trying to use Rails 3.0.1 with Ruby 1.8.7, but I get the same
error if I switch to 3.0.0. Anyway, Rails 3.0 works with Ruby 1.8.7 (or
at least it should)...

Yes, you are right of course, and the error is actually saying

=1.8.7, which you have. Does it matter though, apart from acedemic

interest? If it works ok for you using ruby 1.9.2 then just use that.

Colin