I cannot install Rails 3.0 on my OS X

Hi,

I've upgraded ruby to 1.8.7.
But when I tried to install rails 3.0, it said that I need ruby 1.8.7 or
higher.

ruby-1.8.7-p248$ ruby -v
ruby 1.8.7 (2009-12-24 patchlevel 248) [i686-darwin9.8.0]
ruby-1.8.7-p248$ sudo gem install rails --pre
ERROR: Error installing rails:
  activesupport requires Ruby version >= 1.8.7.

What should I do?

Sam

Try installing RVM and though it installing Ruby 1.9.1 or 1.9.2
Ruby 1.9.2 is recommended as of this moment.
Works for me ... although I have some issues on the latter steps.

It might be possible that you have two versions of ruby and two
versions of rubygems. When you run the application the gem installer
seems to get the path of the old environment. Try gem env or sudo gem
env and see the ruby version and ge path.

When the problem will be solved, I suggest to keep a standard ruby
installation in your Mac and use rvm to install other version. I
prefer to leave the current system version of Ruby, then I install rvm
and I load the ruby version that I want, for instance I have installed
ree, jruy, MRI 1.8.7 and 1.9.1.