installing ruby 1.9.3 in michael hartl's ruby on rails tutorial

The problem is solved! see http://stackoverflow.com/questions/14029119/installing-ruby-1-9-3-in-michael-hartls-ruby-on-rails-tutorial/14085987#14085987