install rails3 --pre on snow leopard w ruby 1.8.7 -- memcache_client gem problems

Hello,

Following the indications listed here:
http://weblog.rubyonrails.org/2010/2/5/rails-3-0-beta-release/

in other words:
sudo gem install tzinfo builder memcache-client rack rack-test rack-
mount erubis mail text-format thor bundler i18n
sudo gem install rails --pre

The first line installed gems without complaint. When I tried the
second (sudo gem install rails --pre), it complains:
ERROR: Error installing rails:
   activesupport requires memcache-client (~> 1.7.5, runtime)

However:
gem list --local | grep memc
memcache-client (1.8.0)

So I checked and, from irb:
>> require 'memcache'
[memcache-client] Could not load SystemTimer gem, falling back to
Ruby's slower/unsafe timeout library: no such file to load --
system_timer

OK so I added that:
sudo gem install system_timer

And now from irb it seems OK:
>> require 'memcache'
=> true
>> MemCache::VERSION
=> "1.8.0"

But install of rails --pre still gives no joy:
sudo gem install rails --pre
ERROR: Error installing rails:
   activesupport requires memcache-client (~> 1.7.5, runtime)

Any ideas?

Thanks,
Ben

Following the indications listed here:http://weblog.rubyonrails.org/2010/2/5/rails-3-0-beta-release/

in other words:
sudo gem install tzinfo buildermemcache-clientrack rack-test rack-
mount erubis mail text-format thor bundler i18n
sudo gem install rails --pre

The first line installed gems without complaint. When I tried the
second (sudo gem install rails --pre), it complains:
ERROR: Error installing rails:
activesupport requiresmemcache-client(~> 1.7.5, runtime)

Are you using jruby by chance?
Have a look at `gem env`
If it shows "RUBYGEMS VERSION: 1.3.3" and a gem path involving Jruby
you'll run into trouble.

I just dusted off my old ubuntu box and started installing rails 3 and
ran into this. If it is Jruby, clean up your paths to use MRI or maybe
setup RVM(Ruby Version Manager).

No this was regular (not j-) ruby, 1.8.7.
I think my problem was related to rubygems, at the time I still had
1.3.5.

Later I installed rvm and, again using ruby 1.8.7, I had more luck
doing a fresh start by first updating rubygems to 1.3.6 and then
running only gem install rails --pre, which automatically grabbed all
the gems needed. This way it grabbed memcache_client 1.7.8 (not 1.8.0)
and the whole thing worked without a hitch.

So I'd replace the advice listed on the guides with:
1) update rubygems to 1.3.6 (gem update --system #or whatever
equivalent you need to do so)
2) then do: gem install rails --pre

With ruby 1.8.7 on snow leopard, that's all it needs.