index.html in rails-app/public

Hello All,

I have created a rails application on hosrtmonster and created
symbolic link of app's public folder. Now default link is to
index.html of rails-app/public folder.
I want to set another page as homepage. I also set root in routes.rb
file but its not working, also remove default index.html from public
folder.

Can anyone tell me how to add link
rails-app/app/views/home/index.html.erb to index.html in
/rails-app/public folder webpage?

If i have created symbolic link to rails-app/../../home then its not
working. .html.erb file is not working directly in browser.

Sorry I cannot understand what you are trying to do.
What URL are you trying to use?
Are you trying to run a controller action from that url? Is so what
controller and action?

Colin

<snip>

Sorry I cannot understand what you are trying to do.
What URL are you trying to use?
Are you trying to run a controller action from that url? Is so what
controller and action?

I have created a rails app on hostmonster and there to run any rails I
have to create symbolic link to rails app like
$ ln -s ~/APPNAME/public ~/public_html/APPNAME

I also created home controller using
$ rails generate controller home

Then I have removed index.html from rails-app/public (default page).
when I open that link then it gives folder files
check this http://simak.in/blog

I also set the routes.rb file for home controller but still not working.
How to set route to any controller through public folder of app.

Now are you getting or still have confusion. I am not able to explain
my problem properly. Please try to understand and help me.

Thanks in advance.

just remove the index.html in the /public folder.

I have deleted index.html. Now check: http://blog.simak.in/
Its not working. What to do now ?

I hope its not pointing to your rails application folder and its pointing to some other folder in server and there by you are getting the default page.

Thank You,
Uma Mahesh.

Also, check if Apache or Nginx is set to provide a default index in folders that don't contain one. mod_autoindex or similar…

Walter

<snip>

Also, check if Apache or Nginx is set to provide a default index in folders that don't contain one. mod_autoindex or similar...

I am not getting this. Means i have to remove this apache setting that
automatically create default index page?

If you're using Apache and Passenger, try adding this line inside the <Directory> block in the relevant httpd.conf for this application:

Options -Indexes

Restart Apache and see if that fixed it for you. It really only will if Options +Indexes is set at a higher level in your general Apache configuration file tree. I'm just guessing here, hope it helps.

Walter

<snip>

I am not getting this. Means i have to remove this apache setting that
automatically create default index page?

If you're using Apache and Passenger, try adding this line inside the <Directory> block in the relevant httpd.conf for this application:

Options -Indexes

Restart Apache and see if that fixed it for you. It really only will if Options +Indexes is set at a higher level in your general Apache configuration file tree. I'm just guessing here, hope it helps.

Walter

Ok I'll try this.
Thanks.

<snip>

If you're using Apache and Passenger, try adding this line inside the <Directory> block in the relevant httpd.conf for this application:

Options -Indexes

Restart Apache and see if that fixed it for you. It really only will if Options +Indexes is set at a higher level in your general Apache configuration file tree. I'm just guessing here, hope it helps.

Walter

I tried this now see the result blog.simak.in.
I think ruby on rails app is not working on hostmonster.

for your first app, you should try using heroku. it it much simpler to get an app up and running than the current path you are taking.

Jason