Inconsistency in use of user_name and username

At first it appeared to me in the smtp settings, the username has to be specified as “user_name”, but the comment in the source is naming it “username”.

  • :user_name - If your mail server requires authentication, set the username in this setting.


And doing a search on “user_name” and “username” in the repository both give quite some results.

I think making this consistent could make things more clear, and makes typing configuration possible, instead of copy-pasting.

Would need to change everywhere that it’s being called, add a deprecation and work with both values for now.

Looks like :username is found more often in the codebase 334 times compared to user_name coming in at 231.