Importing Source Code

Hi,

New to RoR and have been assigned a pretty hefty task. I have to alter
some source code for a company, the only problem is when I import the
project (using Netbeans) and use terminal to start the server (same
error for mongrel and Webrick) I get this error explosion:

=> Booting Mongrel
=> Rails 2.3.2 application starting on http://0.0.0.0:3000
/usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require': no such file to load -- prawn
(MissingSourceFile)
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in
`require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in
`new_constants_in'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in
`require'
    from
/home/ben/Documents/LIMSDev/vendor/plugins/prawnto/lib/prawnto.rb:4
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in
`require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in
`new_constants_in'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in
`require'
    from /home/ben/Documents/LIMSDev/vendor/plugins/prawnto/init.rb:1:in
`evaluate_init_rb'
    from
./script/../config/../vendor/rails/railties/lib/rails/plugin.rb:146:in
`evaluate_init_rb'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/core_ext/kernel/reporting.rb:11:in
`silence_warnings'
    from
./script/../config/../vendor/rails/railties/lib/rails/plugin.rb:142:in
`evaluate_init_rb'
    from
./script/../config/../vendor/rails/railties/lib/rails/plugin.rb:48:in
`load'
    from
./script/../config/../vendor/rails/railties/lib/rails/plugin/loader.rb:38:in
`load_plugins'
    from
./script/../config/../vendor/rails/railties/lib/rails/plugin/loader.rb:37:in
`each'
    from
./script/../config/../vendor/rails/railties/lib/rails/plugin/loader.rb:37:in
`load_plugins'
    from
./script/../config/../vendor/rails/railties/lib/initializer.rb:348:in
`load_plugins'
    from
./script/../config/../vendor/rails/railties/lib/initializer.rb:163:in
`process'
    from
./script/../config/../vendor/rails/railties/lib/initializer.rb:113:in
`send'
    from
./script/../config/../vendor/rails/railties/lib/initializer.rb:113:in
`run'
    from /home/ben/Documents/LIMSDev/config/environment.rb:13
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in
`require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:521:in
`new_constants_in'
    from
/home/ben/Documents/LIMSDev/vendor/rails/activesupport/lib/active_support/dependencies.rb:156:in
`require'
    from
/home/ben/Documents/LIMSDev/vendor/rails/railties/lib/commands/server.rb:84
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in
`gem_original_require'
    from /usr/lib/ruby/1.8/rubygems/custom_require.rb:31:in `require'
    from script/server:3

Anyone know why I'm getting this error ? I can't really seem to find
specific reasons after searching for quite some time.

p.s.

hopefully this is the right forum, if not I'd appreciate being pointed
in the right direction :slight_smile:

Seriously? It mean exactly what it says: the app requires the 'prawn'
gem.

Open a terminal window and type gem list --local

If prawn's not in that list, install it. ( sudo gem install prawn )

HTH,