about configuration ror (i'm tiro)

hi,

i'm using ubuntu9.04, download ruby Source code and make it.

install rails 2.3.4
$rails /var/www/hello is work
but when $ ruby script/generate migration hello_db

System tell me:
/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/initializer.rb:
271:
in `rescue in require_frameworks': no such file to load -- jopenssl
(RuntimeError) from

/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/initializer.rb:
268:in `require_frameworks' from

/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/initializer.rb:
134:in `process' from

/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/initializer.rb:
113:in `run' from

/home/lizhixin/NetBeansProjects/hellolizhixin/config/environment.rb:
9:in `<top (required)>' from

/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/commands/
generate.rb:1:in `require' from

/usr/local/lib/ruby/gems/1.9.1/gems/rails-2.3.4/lib/commands/
generate.rb:1:in `<top (required)>' from

script/generate:3:in `require' from script/generate:3:in `<main>'

     thanks