Heroku, Ruby on Rails, GitHub

1. I get the following message after I have run '$git push heroku
master' at the command line:

This is the message:

An error occurred while installing sqlite3 (1.3.8), and Bundler cannot
continue.
       Make sure that `gem install sqlite3 -v '1.3.8'` succeeds before
bundling.

!
! Failed to install gems via Bundler.
!
! Detected sqlite3 gem which is not supported on Heroku.
! https://devcenter.heroku.com/articles/sqlite3
!

! Push rejected, failed to compile Ruby app

2. Prior to running '$git push heroku master', I ran '$heroku create',

which gave me the following url:

http://stark-fjord-8580.herokuapp.com/

3. In my browser this message was generated, before I ran '$git push
heroku master'

Heroku | Welcome to your new app!
Refer to the documentation if you need help deploying.

4. I have commented #out the sqlite3 gem in my gemfile and I have run
'$bundle'

5. I have yet to see Heroku work properly

6. this is the final part of the error message:

To git@heroku.com:stark-fjord-8580.git
! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'git@heroku.com:stark-fjord-8580.git'

Does anyone know what occurred and how I can fix this?

Heroku doesn't do SQLite. Use Postgres, at least in production.

-Dave

I thought that heroku made the substitution automatically for you. Dim memory. Do they try anything like that?

I also recall that from a very long time ago, but AFAIK it hasn't
been the case for quite a while.

What heroku *does* do is provide pretty good documentation on
how to deploy to their platform, e.g.

  https://devcenter.heroku.com/articles/getting-started-with-rails3

which is the first result of googling 'deploying rails app to heroku'
(and specifically discusses DB requirements) ...