Help to send email required

From a Rails application containing email addresses I want to send emails. Therefore I am testing sending emails.

It does not work though I have read a lot about how to do it. I guess my …/config/initializers/mail.rb is wrong.

I have based the settings on the answers here but I do not understand them fully.

File content:

ActionMailer::Base.smtp_settings = { address: “smtp.x.y”, port: 465, domain: “x.y” user_name: “me”, password: “my”, authentication: :login, enable_starttls_auto: true }

This is based on my settings in Thunderbird for outgoing server:

Server Name smtp.x.y Port 465 User name me Authentication method Normal password Connection Security SSL/TLS

The error is reported as

Completed 500 Internal Server Error in 60254ms

Timeout::Error (Timeout::Error): app/controllers/mail_messages_controller.rb:56:in block in create' app/controllers/mail_messages_controller.rb:54:in create’

OS Ubuntu 12.04 Ruby 1.9.3 Rails 3.2.9

mailers/user_mailer.rb class UserMailer < ActionMailer::Base default from: “youremailaddress”

  # Subject can be set in your I18n file at config/locales/en.yml
  # with the following lookup:

Hmmm, You really repeat one of the points that make confused - :domain => “yourwebsite”,

I am running on my client, localhost, and do not have any own web address, so what should domain be set to?

Hi, Sorry I do not know. This also confused me. Try using a name associated with your email service provider. It should not have anything to do with where your app server is running from.


I tried to set up a different mail account I have. The response was different “Connection refused - connect(2)”. This is OK, I believe, because my ISP does not allow mail relay.

So obviously I get in touch with my ISP but am unable to login. Any hints?

Problem solved!

Careful inspection of the Thunderbird outgoing server settings revealed that my mailer smtp.x.y required the following settings in …/config/initializers/mail.rb:

ActionMailer::Base.smtp_settings = { … :enable_starttls_auto => false, :ssl => true }

Once this was corrected I got the report that the from field in the mail had to contain an existing domain.

domain in the smtp_settings is set to x.y where x.y is taken from address => smtp.x.y but I do not know if this of any importance.

Thanks for all hints.