I agree this syntax is more verbose, but perhaps it should stay this way so the developer doesn’t have to make too many decisions on which API to use.
The frequent mistake for underexperienced Rails devs using AR associations is that they tend to call “Project.tasks”, forgetting that “tasks” is an association defined on a particular Project instance, not at class level. Adding all associations to class level will just confuse people, IMO.