Going live--which mongrel version?

It looks like mongrel has diversified since the book came out. There
are now both java & ruby versions of mogrel available. I expect that
I want ruby. Is this correct?

Most likely unless you use JRuby or Ruby in Windows platform.