getting started on capistrano

i'm trying to set up capistrano deployment for the first time. going
through the manuals on the ruby on rails site seem pretty self
explanatory but when i run rake deply, it fails. it shows a long string
of commands that it was trying to run when it failed but i don't see
any specific errors or anything.

plus, when i try to use rake show_deploy_tasks, i get an error saying
that it doesn't know how to build the task. am i doing something wrong
here? where can i go to find out what it going wrong?

ok, sorry. i am able to see the errors, i wasn't looking in the right
place.

the error says "bash: line 2: svn: command not found"

i don't understand why it's saying that though because svn is installed
on that server. that also doesn't tell me why my other rake tasks
aren't working:

rake show_deploy_tasks and rake restart

When you ssh in as the user you specified, can you always type svn on
a prompt by itself to get svn?

it might not be reading your .bash_profile on login, if this is the
case, you can add to your deploy.rb file somewhere:

set :svn, "/usr/bin/svn"

or wherever the full path to svn is you can find it by typing: whereis svn

And, there are no tasks like the one you specified.

You can issue:

rake remote:show_tasks and rake remote:restart

which are helper methods for:

rake remote:exec ACTION="show_tasks" and rake remote:exec ACTION="restart"

thank you. i did figure out how to add the path for svn, and that is
working now. any ideas why it's not picking up the path in my
.bash_login?

also, you said that those rake tasks did not exist... did they exist
with an older version of capistrano? i was getting my information
straight off of the ruby on rails site:

http://manuals.rubyonrails.com/read/chapter/98#page264

the 2nd paragraph down on the deploying section says that you can run
"rake show_deploy_tasks" i did try your suggestion and that worked
great though.

Thanks