Getting error while starting server plz help

c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator/options.rb:32:in
`default_options': undefi
ned method `write_inheritable_attribute' for
Rails::Generator::Base:Class (NoMethodError)
        from
c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator/base.rb:90:in
`<class:Base>'
        from
c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator/base.rb:85:in
`<module:Genera

'

        from
c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator/base.rb:48:in
`<module:Rails>
'
        from
c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator/base.rb:6:in
`<top (required)

'

        from
c:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
c:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator.rb:37:in
`<top (required)>'
        from
c:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
c:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
        from
c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/bin/rails:15:in `<top
(required)>'
        from c:/Ruby193/bin/rails:23:in `load'
        from c:/Ruby193/bin/rails:23:in `<main>'

Has your server started without errors before? If so then, what have you changed (in the broadest sense: upgrade OS, ruby, rails version etc.?) since the last time it worked.

In case it hasn’t worked at all, let us know how you installed your ruby/rails/gems.

Gintautas S. wrote in post #1070411:

Has your server started without errors before? If so then, what have you
changed (in the broadest sense: upgrade OS, ruby, rails version etc.?)
since the last time it worked.

In case it hasn't worked at all, let us know how you installed your
ruby/rails/gems.

I am new to Ruby/rails platform:

i have followed following steps on my Virtual machine

1) installed one click installer
then
2) gem install rails --remote
3) gem update --system

then installed devkit

--> ruby dk.rg init
--> ruby dk.rg review
--> ruby dk.rg install

Gintautas S. wrote in post #1070411:


then i checked out code from SVN after after that i am trynig to run
server

–> rails server

It looks like you’re running rails 2.x, and on rails 2.x you start the server with

ruby script/server

Definitely worth checking that you’ve installed the version of rails the app was designed to run against.

Fred

I am sure that I am using rails 3. Can someone help me

Your original post:

c:/Ruby193/lib/ruby/gems/1.9.1/gems/rails-2.3.14/lib/rails_generator/options.rb:32:in
`default_options': undefined method `write_inheritable_attribute' for
Rails::Generator::Base:Class (NoMethodError)

What version of the Rails gem do you see there? :slight_smile:

How can I confirm that kind let me know

rails -v

in console.