gem update --system issue

I run the command

$gem update --system

after all time while installing gems and even

$rails -v

command also giving below error

Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json-1.6.1.gemspec]: invalid date format in specification: "2011-09-18
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json-1.6.0.gemspec]: invalid date format in specification: "2011-09-12
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
uuid-2.3.4.gemspec]: invalid date format in specification: "2011-09-02
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
gherkin-2.5.1.gemspec]: invalid date format in specification:
"2011-09-23 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json_pure-1.5.4.gemspec]: invalid date format in specification:
"2011-08-31 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
cucumber-1.1.0.gemspec]: invalid date format in specification:
"2011-09-22 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json-1.5.4.gemspec]: invalid date format in specification: "2011-08-31
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
spruz-0.2.13.gemspec]: invalid date format in specification:
"2011-08-17 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json-1.6.1.gemspec]: invalid date format in specification: "2011-09-18
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json-1.6.0.gemspec]: invalid date format in specification: "2011-09-12
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
uuid-2.3.4.gemspec]: invalid date format in specification: "2011-09-02
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
gherkin-2.5.1.gemspec]: invalid date format in specification:
"2011-09-23 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json_pure-1.5.4.gemspec]: invalid date format in specification:
"2011-08-31 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
cucumber-1.1.0.gemspec]: invalid date format in specification:
"2011-09-22 00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
json-1.5.4.gemspec]: invalid date format in specification: "2011-08-31
00:00:00.000000000Z"
Invalid gemspec in [/usr/local/lib/ruby/gems/1.9.1/specifications/
spruz-0.2.13.gemspec]: invalid date format in specification:
"2011-08-17 00:00:00.000000000Z"

Any solution ?

Are you trying to install rails 3.1??

Try using `update_rubygems’

ok

Updated Rails to 3.1.1 and noticed this ‘undocumented deprecation’ of try() method behavior.

In Rails 3.1.0 and earlier:

nil.try(:method) => allways Nil

object.try(:method) => executes method if defined, or returns Nil if NoMethodError exception raised.

In Rail 3.1.1

nil.try(:method) => allways Nil

object.try(:method) => executes method if defined, or raise NoMethodError exception directly if just send() method would be called!

That is important deprecation. I think Try should definitely ignore NoMethodError.

Now i have to rewrite some code…