Not able to update

Hi,

I am new to ruby.
OS: Windows XP
Ruby Version --ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]
When i run
gem update --system after installing ruby

I am getting this error

C:\Documents and Settings\abhisheksreepal>gem update --system
Updating RubyGems
Updating rubygems-update
ERROR: While executing gem ... (Gem::InstallError)
    invalid gem format for C:/Ruby/lib/ruby/gems/1.8/cache/rubygems-
update-1.3.5
.gem