gem install problem: fcgi

@Nick.
Abandon hope for doing this on Windows. It’s not possible. :slight_smile:

There are other ways to deploy on Windows. If you’re developing, you simply don’t need to do anything other than using ruby script/server. Deployment is different but there are better options than Fastcgi.

I’ve written about this extensively on this list as well as in this book:

http://www.pragprog.com/titles/fr_deploy

Bottom line: Ruby on Windows is much slower. I deploy lots of apps on it though with success. The approach you want to look at is to use a combination of Apache 2.2 with mod_proxy_balancer and several instances of your app running via Mongrel. This is very similar to how it’s done on the *nix side now. You can hide all this behind an existing IIS installation using the ISAPI_REWRITE filter and a plugin I wrote called reverse_proxy_fix.

Setting this all up is a bit complicated at first, but it’s all covered in the aforementioned book. Alternatively, set up a linux VM on top of Windows and deploy your app to that. You’ll then be able to automate it using Capistrano or other tools.

If you need more info, contact me off list and I can try to help you.

I'm having this same problem, except on linux...

have_header: checking for fastcgi/fcgiapp.h... -------------------- no

"gcc -E -I. -I/usr/lib64/ruby/1.8/x86_64-linux -I. -O2 -g -Wall -
fPIC conftest.c -o conf
test.i"
conftest.c:1:29: fastcgi/fcgiapp.h: No such file or directory
checked program was:
/* begin */
1: #include <fastcgi/fcgiapp.h>
/* end */