Rails installation does not work on windows

Hi,

i wanted to upgrade my rails installation that worked for quite a
while. So i did the obvious

gem install rails

but the fcgi gem fails with an error message

Building native extensions. This could take a while...
ERROR: While executing gem ... (Gem::Installer::ExtensionBuildError)
    ERROR: Failed to build gem native extension.

ruby extconf.rb install rails
checking for fcgiapp.h... no
checking for fastcgi/fcgiapp.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --srcdir=.
        --curdir
        --ruby=c:/ruby/bin/ruby
        --with-fcgi-dir
        --without-fcgi-dir
        --with-fcgi-include
        --without-fcgi-include=${fcgi-dir}/include
        --with-fcgi-lib
        --without-fcgi-lib=${fcgi-dir}/lib

Gem files will remain installed in c:/ruby/lib/ruby/gems/1.8/gems/
fcgi-0.8.7 for inspection.
Results logged to c:/ruby/lib/ruby/gems/1.8/gems/fcgi-0.8.7/ext/fcgi/
gem_make.out

I did not find any hints on this in the forum except other users
having the same issue. However no answer to their quesion.

My existing rails installation was broken afterwards. I tries a clean
install (Ruby from scratch, Rails from scratch) same error. Now Rails
is out of order.

How can I fix this ? I have several infrastructure components build
with Rails running on Windows so I need a working rails environment ?

Thanks for any support,
Arno

try to use this command

gem update --system

then try to execute

gem install rails

This helped. Thanks a lot.