Freeze and dependence problems?

Hello

I have a server using Rails 1.1.6

So I developed my application on my computer, with Rails 2.1
After that I did a rake rails:freeze:gems. That sent Rail gems was sent
to /vendor/rails
I sent my application to server, configured, and everything was working
fine, using Rails 2.1 Freezed Version.

Now I need to install a plugin (will_paginate).
But when I try to 'require' it, it says my Active Support is too old.

See? Application is freezed in 2.1 and script/about confirm that
When I try to require, it says my gems are 1.1.0!

Anyone know what can I do?

will_paginate probably doesn't realise that a non gem version of
activesupport is already loaded. Are you using the latest version of
will_paginate ?

Fred

Frederick Cheung wrote:

Fixed it commenting

s.add_dependency(%q<activesupport>, [">= 1.4.4"])

in gems\specifications\mislav-will_paginate-2.3.2.gemspec

Working now :slight_smile: