"can't activate activesupport" error

Hi,

I've got a production server with rails 1.2.3 installed. Previously my
app had frozen rails 1.2.3 as well. I decided to update frozen rails
to 1.2.6.

Deployment went fine until rake task was executed, which resulted in
the following error:

rake aborted!
can't activate activesupport (>= 1.4.4), already activated
activesupport-1.4.2]

On the server there's installed activesupport 1.4.2 (by rails 1.2.3)
and 1.4.4 needed by will_paginate gem.

The 1.4.4 it's complaining about is used by frozen rails 1.2.6. I
can't update rails gem to 1.2.6, because there are other rails app
running.

"mongrel_rails cluster::start -C ..." command says "Starting 3
Mongrel servers...", but mongrels are not started.

Do you guys have any idea how to fix it?

BTW. How does one revert deployment made by capistrano/deprec? Can I
simply modify "current" link to previous release?

Szymon Nowak wrote:

rake aborted!
can't activate activesupport (>= 1.4.4), already activated
activesupport-1.4.2]

Try uninstalling 1.4.2, 1.4.4 will gladly take over all necessary
duties.

Thanks, but rails 1.2.3 requires activesupport 1.4.2, right? I'd like
to have rails 1.2.3 gem installed and use frozen rails 1.2.6.

Regards,
Szymek