error when using active_record_store which doesn't happen using cookie_store ...

when I start my app with cookie_store, no error…

but when I change for active_record_store ( because of cookies overflow…) then I get an error :

TypeError in WelcomeController#home

can't convert Symbol into String

Rails.root: /Users/yves/github/local/yoogroop

Application Trace | Framework Trace | Full Trace

rack (1.4.1) lib/rack/utils.rb:219:in `+'

rack (1.4.1) lib/rack/utils.rb:219:in `set_cookie_header!'

rack (1.4.1) lib/rack/session/abstract/id.rb:342:in `set_cookie'

rack (1.4.1) lib/rack/session/abstract/id.rb:330:in `commit_session'

rack (1.4.1) lib/rack/session/abstract/id.rb:206:in `context'

rack (1.4.1) lib/rack/session/abstract/id.rb:200:in `call'

actionpack (3.2.8) lib/action_dispatch/middleware/cookies.rb:339:in `call'

activerecord (3.2.8) lib/active_record/query_cache.rb:64:in `call'

activerecord (3.2.8) lib/active_record/connection_adapters/abstract/connection_pool.rb:473:in `call'

full trace at : https://gist.github.com/4046578

using a debugger in the WelcomeController#home

class WelcomeController < ApplicationController

respond_to :html

before_filter :store_location

before_filter :authenticate_user!, :only => :page3

def home

debugger

end

the issue seems to be originated after the rendering... ( which is the same when I use the cookie_store)

Processing by WelcomeController#home as HTML

Parameters: {"locale"=>:en}

Rendered welcome/home.en.html.haml within layouts/application (6.3ms)

Rendered layouts/users/_language.html.haml (15.9ms)

Rendered layouts/users/_navbar.html.haml (1173.4ms)

Rendered layouts/users/_footer.html.haml (3.4ms)

Completed 200 OK in 112208ms (Views: 2885.3ms | ActiveRecord: 0.0ms)

what could be wrong .. any clue ?

not solved but seems to be an issue related to

active_record_store “domain: :all” TypeError

https://github.com/rails/rails/issues/2483