error of "rake test" command

Hi,

I have an error when i use rake test, plz help

akyen@ubuntu:~/Desktop/p$ rake test
WARNING: Global access to Rake DSL methods is deprecated. Please
include
    ... Rake::DSL into classes and modules which use the Rake DSL
methods.
WARNING: DSL method Pictographs::Application#task called at /usr/local/
lib/ruby/gems/1.9.1/gems/railties-3.0.7/lib/rails/application.rb:
215:in `initialize_tasks'
/usr/local/lib/ruby/gems/1.9.1/gems/activesupport-3.0.7/lib/
active_support/whiny_nil.rb:48:in `method_missing': undefined method
`should_not_be_valid' for nil:NilClass (NoMethodError)

Thank you very much

Yennie

Please include your test that is failing here.

Most probably the issue is that you are expecting a object somewhere in the test, but it is nil instead.

Chirag
http://sumeruonrails.com

I did not have any test on my project. i just use bundle update rake

and then, it gives me that error…

plz help

thanks

I did not have any test on my project. i just use bundle update rake
and then, it gives me that error…

and I have 2 version of rake (0.9.2 / 0.8.7)

do you know anyway that i can switch back to 0.8.7

Try using ‘bundle exec rake test’ instead of just ‘rake test’

Chirag
http://sumeruonrails.com

Try using ‘bundle exec rake test’ instead of just ‘rake test’

it gives me this error "

en@ubuntu:~/Desktop/Pictographs$ bundle exec rake test

/usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.14/lib/bundler/rubygems_integration.rb:197:in `block in replace_bin_path’: can’t find executable rake (Gem::Exception)

from /usr/local/bin/rake:19:in `<main>'"

Maybe your rake installation has become corrupt.

Try re-installing it:

#Uninstall the current rake gem

sudo gem uninstall rake

#Install the version that you need

sudo gem install rake -v=0.8.7

Chirag
http://sumeruonrails.com

thanks Chirag… it works fine now…