Error of rake (rake spec)

Hi,

I have a problem when i type rake or rake spec to test my file
it asks me to install the extension and check the version of bson and
mongo

Using mongo (1.3.1)
Using bson (1.3.1)

but i have no idea where my load path is. so that i cannot make sure
is bson_ext is in my load path or not

please help

yen@ubuntu:~/Desktop/Pictographs$ rake
(in /home/yen/Desktop/Pictographs)

**Notice: C extension not loaded. This is required for optimum MongoDB
Ruby driver performance.
  You can install the extension as follows:
  gem install bson_ext

  If you continue to receive this message after installing, make sure
that the
  bson_ext gem is in your load path and that the bson_ext and mongo
gems are of the same version.

/usr/local/bin/ruby -S bundle exec rspec ./spec/functional/
users_controller_spec.rb

**Notice: C extension not loaded. This is required for optimum MongoDB
Ruby driver performance.
  You can install the extension as follows:
  gem install bson_ext

  If you continue to receive this message after installing, make sure
that the
  bson_ext gem is in your load path and that the bson_ext and mongo
gems are of the same version.

Mongoid config not found. Create a config file at: config/mongoid.yml
to generate one run: rails generate mongoid:config

/home/yen/Desktop/Pictographs/spec/spec_helper.rb:12:in `block in <top
(required)>': uninitialized constant Mongoid::Matchera (NameError)
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core.rb:79:in `configure'
  from /home/yen/Desktop/Pictographs/spec/spec_helper.rb:11:in `<top
(required)>'
  from /home/yen/Desktop/Pictographs/spec/functional/
system_controller_spec.rb:1:in `require'
  from /home/yen/Desktop/Pictographs/spec/functional/
system_controller_spec.rb:1:in `<top (required)>'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/configuration.rb:419:in `load'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/configuration.rb:419:in `block in load_spec_files'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/configuration.rb:419:in `map'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/configuration.rb:419:in `load_spec_files'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/command_line.rb:18:in `run'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/runner.rb:80:in `run_in_process'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/runner.rb:69:in `run'
  from /usr/local/lib/ruby/gems/1.9.1/gems/rspec-core-2.6.4/lib/rspec/
core/runner.rb:11:in `block in autorun'
rake aborted!
ruby -S bundle exec rspec ./spec/functional/
system_controller_spec.rb ./spec/functional/users_controller_spec.rb
failed

(See full trace by running task with --trace)