Error Installing Rails

Hi, I'm receiving the following error message using

BEGIN ERROR:

host_name:~/src conradwt$ sudo gem install rails --include-dependencies
Password:
ERROR: While executing gem ... (Errno::ECONNREFUSED)
    Connection refused - connect(2)

END ERROR:

BEGIN MORE INFO:

host_name:~/src conradwt$ sudo gem install rails
--include-dependencies --backtrace
Password:
ERROR: While executing gem ... (Errno::ECONNREFUSED)
    Connection refused - connect(2)
/usr/local/lib/ruby/1.8/net/http.rb:562:in `initialize'
/usr/local/lib/ruby/1.8/net/http.rb:562:in `connect'
/usr/local/lib/ruby/1.8/timeout.rb:48:in `timeout'
/usr/local/lib/ruby/1.8/timeout.rb:76:in `timeout'
/usr/local/lib/ruby/1.8/net/http.rb:562:in `connect'
/usr/local/lib/ruby/1.8/net/http.rb:555:in `do_start'
/usr/local/lib/ruby/1.8/net/http.rb:544:in `start'
/usr/local/lib/ruby/1.8/net/http.rb:1031:in `request'
/usr/local/lib/ruby/1.8/net/http.rb:800:in `head'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:118:in
`read_size'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:106:in `get_size'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:54:in `size'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/incremental_fetcher.rb:60:in
`remote_size'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/incremental_fetcher.rb:33:in
`source_index'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:365:in
`source_index'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:482:in
`fetch_source'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:473:in
`source_index_hash'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:472:in
`source_index_hash'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:436:in `install'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:258:in `execute'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_commands.rb:220:in `execute'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:69:in `invoke'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:117:in `process_args'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:88:in `run'
/usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:29:in `run'
/usr/local/bin/gem:23

END MORE INFO:

BTW, I'm trying to install on a MBP. Well, I must go and I appreciate
any assistance that I may receive.

Thanks in advance,

-Conrad

Looks like a network connection problem.

Hi, I was able to complete all the previous steps which involved using
the network. Now, I'm totally stopped in my tracks.

-Conrad

Frederick Cheung wrote:

Forgot to say, you can use one of the various rubyforge mirrors, eg
gem install rails --source http://rubyforge.planetargon.com/
gems.rubyforge.org/

Thanks for that... it fixed my problems.

I'm surprised they don't have an automated mirror system, like some of
the other package systems do. Works well to get a static list of
mirrors from a reliable web host, and then work down that list until
you find one that's up.

Smackfu