ERB VS rhtml

I have the addison wesley RailsSpace book to learn Ruby on Rails,and
I am wondering why my version of ruby uses and crestes .erb files rather
than rhtml files. It is making it very difficult to follow the book as
some examples dont work correctly or as they should in the book. What
changes do I need to make in order to use my version of Ruby with this
book?
My version is ruby -v 1.8.6 (2007-09-24 patchlevel 111) [x86_64-linux]

It's not the version of ruby that's the issue, it's the version of
rails. See:

http://railsspace.com/

For instructions on installing a railsspace-compatible version of rails.

HTH,

-Roy

Thanks for the quick reply , but this seems to have failed for some
reason
sudo gem install rails -v 1.2.3 --include-dependencies
[sudo] password for baxter:
INFO: `gem install -y` is now default and will be removed
INFO: use --ignore-dependencies to install only the gems you list
Updating metadata for 24 gems from http://gems.rubyforge.org/
........................
complete
ERROR: could not find rails locally or in a repository

Roy Pardee wrote:

Is this an issue with repos, ergo do I need to use older repos?

I guess to be more specific
I am running Ubuntu 8.01 x86_64
ruby -v 1.8.6 (2007-09-24 patchlevel 111) [x86_64-linux]
rails 2.02
and want to roll back to rails 1.2.3
I am now looking for a manual safe way to do this.

Not sure, tho I tend to doubt it. I would try uninstalling rails and
then just doing an install of the desired version.

HTH,

-Roy

OP,

do you mean that it’s creating .erb.html files instead of .rhtml files?

Also, to install an older version of rails the correct syntax is:

gem install rails -v=1.2.3

You don’t need to specify the include-dependencies option unless you’re using a rubygems version < 1.0.1

Also, to install an older version of rails the correct syntax is:

gem install rails -v=1.2.3

You don't need to specify the include-dependencies option unless you're
using a rubygems version < 1.0.1

Which likely includes anyone who got it from a Linux distro.

Ubuntu Hardy for example ships with:

gem --version

0.9.4

And here I thought I was using a cutting edge distro. :frowning:

.erb.html is the new naming schema for .rhtml, and it’s because you’re using Rails 2.0. There is no difference between the content of these files.

Ryan Bigg wrote:

.erb.html is the new naming schema for .rhtml, and it's because you're
using
Rails 2.0. There is no difference between the content of these files.

yes,this is what I assumed, .. but I am wondering to I have to do a
batch file conversion to rename all the .rhtml files to erb?

Also the above errors I listed occur when using the books finished
example on 2.0

If you look at the error you posted - the complaint is that your install lacks acts_as_ferret - that is the search plugin that RailsSpace uses late in the book.

`gem_original_require’: no such file to load – acts_as_ferret

sudo gem install acts_as_ferret

Should get rid of that error.

I’m not too sure on the batch renaming of the files, sorry.

You could probably write a Ruby script.

Cynthia Kiser wrote:

If you look at the error you posted - the complaint is that your install
lacks acts_as_ferret - that is the search plugin that RailsSpace uses
late
in the book.

`gem_original_require': no such file to load -- acts_as_ferret

sudo gem install acts_as_ferret

Should get rid of that error.

--
Cynthia Kiser
cynthia.kiser@gmail.com

Thank you I will try that.

Cynthia Kiser wrote:

If you look at the error you posted - the complaint is that your install
lacks acts_as_ferret - that is the search plugin that RailsSpace uses
late
in the book.

`gem_original_require': no such file to load -- acts_as_ferret

sudo gem install acts_as_ferret

Should get rid of that error.

--
Cynthia Kiser
cynthia.kiser@gmail.com

Now I am getting this
sudo gem install acts_as_ferret
[sudo] password for baxter:
/usr/bin/gem:23: uninitialized constant Gem::GemRunner (NameError)

Your rubygems is still referencing the older version.

http://frozenplague.net/2008/04/03/unintialized-constant-gemgemrunner/

note I have also tried to upload this Railspace 2.0 to my webhosted
webserver which is running rails 2.0 and it fails to start as well.so
its got to be something within the RailsSpace code.

Have you spent any time reading the google group devoted to railsspace?
I bet you'll get better support over there...