Driving me nuts!!! - Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2)

I had to put a new HD in, and now I'm reinstalling everything, and
can't get mysql to fully work. I can't remember how I fixed it. I've
searched everywhere online and can't find anything.

when I try to use the >mysql command I get this:

Can't connect to local MySQL server through socket '/tmp/
mysql.sock' (2)

My first error came in installing mysql here:

It was this step that messed me up:
cd /usr/local/mysql
sudo ./bin/mysql_install_db --user=mysql
sudo chown -R mysql ./var

I can cd the mysql folder, but when I run the second command I get

Installing MySQL system tables...
090428 23:15:26 [ERROR] /usr/local/mysql/libexec/mysqld: Can't find
file: './mysql/db.frm' (errno: 13)
ERROR: 1017 Can't find file: './mysql/db.frm' (errno: 13)

I've been on this for hours. anyone know?

I've had this before, I installed mysql from an ubuntu package and
suddenly it put the socket into /var/run/mysqld/mysqld.sock
You can create or edit /etc/my.cnf and tell it where the socket file
is created, just remember to add a line for each configuration group
(i.e. [client], [mysqld] etc)
You can also tell Rails where the socket is in database.yml

Andrew Timberlake

"I have never let my schooling interfere with my education" - Mark Twain

Wow, ok this solved it:

Instead of using:
sudo ./bin/mysqld_safe --user=mysql

I needed to use:
sudo ./bin/mysql_install_db --user=mysql