Deployment nightmares

Hi all,

I am at wit's end. I have been trying to deploy an app I have been toying with for a couple of months. It's by no means ready, but I have tried lots of different ways of deploying, but because there are so many parts to it and it's pretty much all new to me, I've gotten stuck. At the moment I have a subversion repository with the app in it and instant rails and rad rails on WinXP to deploy from, which I am very happy with. However getting it to deploy from the repository has got me fooled time and again. The server has Apache and SVN and Cap and Mongrel installed so I think most if not all the parts are there. Any advice / help I could be given would be very very very appreciated.

Thanks. Paul.

It sounds like you have all the "right" parts, so it's mostly a matter of getting them working with each other. How far have you gotten, what do you know to work, what parts do you know talk to the other parts, etc.


Thanks for replying Faisal,

Win XP is talking to Subversion - ie. Rad Rails is putting the app into and can export the repository. Apache is up and running. I can log into the repository on a internet browser and see new revisions if I make changes. The rest, I am afraid is rubbish. Capistrano can never see the repository to save itself and I think I have tried every combo of logging into it (in terms of giving it a different url at least). Is the problem that I have a password protected repository? I can also see the "It Works" page on the browser so Apache is definitely up.