cucumber tests failing - No route matches [GET] "/stylesheets

Please help. I am stumped.

I have four engines inside a rails application. The cucumber scenarios run just fine in three of the engines. The fourth fails with the error:

No route matches [GET] “/stylesheets/common_engine/application.css” (ActionController::RoutingError)
/usr/local/ruby-1.9.3/lib/ruby/gems/1.9.1/gems/actionpack-3.2.17/lib/action_dispatch/middleware/debug_exceptions.rb:21:in `call’

I can not see any significant differences between configuration files of the applications that work and this one.

The test/dummy application runs just fine ($ rails server) with RAILS_ENV set to either ‘development’ or ‘test’.

All applications/engines are running ruby 1.9.3, rails 3.2.17, and cucumber 1.3.10. Google did not help.

Thank you.

I’ve added another engine. Again it runs just fine as a stand alone application (test/dummy) and as an engine inside the main application, but this time when I use cucumber it mangles the route. The generated controller name is NamespaceController, instead of Namespace::Controller.

The only significant difference between the various engines is that each time I create a new engine I get different versions of various gems like childprocess, docile, and jquery_rails. Am I getting incompatible versions of these gems? If so, how do I control this when I create a new engine?

Both problems solved.

To solve the first problem, I trashed what I had done and started over. I do not know what went wrong the first time.

The second problem was caused by pilot error.