Could not find [GEM] locally or in a repository

Hey Guys,

How could I fix the following:

"gem install --no-rdoc --no-ri kete-feedzirra"
ERROR: could not find gem kete-feedzirra locally or in a repository
"gem install --no-rdoc --no-ri libxml-ruby"
ERROR: could not find gem libxml-ruby locally or in a repository
"gem install --no-rdoc --no-ri http_url_validation_improved"
ERROR: could not find gem http_url_validation_improved locally or in a
repository
"gem install --no-rdoc --no-ri system_timer"
ERROR: could not find gem system_timer locally or in a repository
"gem install --no-rdoc --no-ri memcache-client"
ERROR: could not find gem memcache-client locally or in a repository
"gem install --no-rdoc --no-ri mime-types"
ERROR: could not find gem mime-types locally or in a repository
"gem install --no-rdoc --no-ri htmlentities"
ERROR: could not find gem htmlentities locally or in a repository
"gem install --no-rdoc --no-ri avatar"
ERROR: could not find gem avatar locally or in a repository
"gem install --no-rdoc --no-ri chronic"
ERROR: could not find gem chronic locally or in a repository
"gem install --no-rdoc --no-ri tiny_mce"
ERROR: could not find gem tiny_mce locally or in a repository
"gem install --no-rdoc --no-ri RedCloth"
ERROR: could not find gem RedCloth locally or in a repository
"gem install --no-rdoc --no-ri unicode"
ERROR: could not find gem unicode locally or in a repository
"gem install --no-rdoc --no-ri hpricot"
ERROR: could not find gem hpricot locally or in a repository
"gem install --no-rdoc --no-ri xml-simple"
ERROR: could not find gem xml-simple locally or in a repository
"gem install --no-rdoc --no-ri zoom"
ERROR: could not find gem zoom locally or in a repository
"gem install --no-rdoc --no-ri packet --version='>= 0.1.14'"
ERROR: could not find gem packet locally or in a repository
"gem install --no-rdoc --no-ri nokogiri"
ERROR: could not find gem nokogiri locally or in a repository

Which versions?

I mean Gem and Ruby

Heinz Strunk wrote:

I mean Gem and Ruby

Heinz,

How would I find this out?

Regards,

Jess

gem -v and ruby -v in your terminal window

Heinz Strunk wrote:

gem -v and ruby -v in your terminal window

gem -v
1.2.0

ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]

Jess,

Can you also do "which gem" from the command line, too, please?

You should see something like what is mentioned under the "Installing
Rails Framework" here:

http://kete.net.nz/documentation/topics/show/261

Cheers,
Walter

By the way, what is probably underlying your problem is that the
version of Ruby and RubyGems you are running is not up-to-date. The
version that is that is available for Debian Lenny as a package is not
up with the latest developments (the migration to GemCutter, etc.).

I think they recently added 1.9.1 to the apt thing. Try this:
sudo apt-get install ruby1.9.1-full

Even though 1.9.2 is out already.

in case you have any issues installing feedzirra... i've written about
installing it here http://seanbehan.com/ruby-on-rails/installing-feedzirra-rss-parser-on-ubuntu-8/

Jess Mckenzie wrote:

Heinz Strunk wrote:

gem -v and ruby -v in your terminal window

gem -v
1.2.0

ruby 1.8.7 (2008-08-11 patchlevel 72) [x86_64-linux]

That's a very old version of gem (current is 1.3.7). You need to
upgrade. Type gem update --system, or if that doesn't work, download an
installer from http://www.rubygems.org .

Best,