connecting to exchange server

I have a public website accessible from the intranet and i have to
send mail to the inside and outside but the thing is when i try to
send mails with postfix apparently the exchange server wont accept
those so i cant send mails to the inside, now im trying to send with
the exchange server but i cant authenticate.

1) is there a better solution with postfix?
2) if not, how do i configure actionmailer to work with exchange
server.

I don't think the issue is specifically postfix. On a couple of different servers, I have gotten Exchange to act as if it was a mail server by adding an MX record for the Web server, set to such a low priority that it won't ever see the light of incoming mail. In one other case, the Exchange admin was able to set a preference somewhere that told it to accept mail from the Web server. The underlying issue in all three cases was that the Exchange server didn't believe that any other machine would be sending mail from "its" domain, so it denied it.

Walter

I don’t think the issue is specifically postfix. On a couple of different servers, I have gotten Exchange to act as if it was a mail server by adding an MX record for the Web server, set to such a low priority that it won’t ever see the light of incoming mail. In one other case, the Exchange admin was able to set a preference somewhere that told it to accept mail from the Web server. The underlying issue in all three cases was that the Exchange server didn’t believe that any other machine would be sending mail from “its” domain, so it denied it.

LOL, yes is true is acting as if anything from its own network is evil, well i can send emails outside and i added an entry in the hosts file for the corresponding domain but postfix isnt working, and there is no info on how to make actionmailer connect to exchange.

Ok i still havent found a solution to this, on my own or in the web, is as if no one has ever set actionmailer to work with exchange.