config/secrets.yml error

Hello All,

I have problems setting up production environment.

Every time I try to run in production mode, it gives me error:

Unexpected error while processing request: Missing secret_key_base for ‘production’ environment, set this value in config/secrets.yml

In Local also if I do ‘rails s -e production’, it gives me the same error.

I tried to setup secret_base from the link - app error: Missing `secret_key_base` for 'production' environment, set this value in `config/secrets.yml` (RuntimeError) · GitHub.

But its still not working.

Can any one help me on this?



Post the file config/secrets.yml here. Check carefully the filename and that it is in the config folder.


first find the secret key by going to the terminal,in your appliaction and then typing 1)$ rake secret this will give you a secret key,then it will give you a big key

2)now copy the secret key and then equal it to SECRET_KEY_BASE=

  1. now type


4)now start the rail production server

rails s -e production

lemme know if you find any difficulty