Changing AV::TestCase to AV::Helpers::TestCase and adding assertions enhancement

Since ActionView::TestCase is mostly used in conjunction with testing
helpers. I'm proposing changing it's namespace. I've added this as a
patch over on Lighthouse:

I've also included in the patch an assertion method to aid in testing
helpers (in core and in individual applications). The methods closely
mirror AC's assert_tag and assert_no_tag. I've named them
assert_tag_in and assert_tag_not_in.
I blogged about using a method similar to this to aid in testing
plugins that add AV helpers:

I also created a branch on github:

I'm seeking feedback of any kind in regards to this patch and