Can't update ActiveSupport gem

I'm getting the message

ERROR: While executing gem ... (ArgumentError)
string contains null byte

My RAILS implementation is now completely out of sync. All other gems
are updated to latest except ActiveSupport. rake rails:update:configs
is aborting because ActiveSupport is wrong version.

Any help would be appreciated!

Now I'm totally hosed. I tried to reinstate an older version of
RAILS, and I can't start my server. The error I'm getting is:

Exiting
/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.3/lib/
active_support/dependencies.rb:477:in `const_missing': uninitialized
constant Gem::Version::NUM_RE (NameError)
        from /usr/local/lib/ruby/gems/1.8/gems/loaded_plugins-0.1.2/
lib/loaded_plugins/plugin.rb:19:in `name_for'
        from /usr/local/lib/ruby/gems/1.8/gems/loaded_plugins-0.1.2/
lib/loaded_plugins/plugin.rb:27:in `initialize'
        from /usr/local/lib/ruby/gems/1.8/gems/loaded_plugins-0.1.2/
lib/loaded_plugins/extensions/initializer.rb:23:in `new'
        from /usr/local/lib/ruby/gems/1.8/gems/loaded_plugins-0.1.2/
lib/loaded_plugins/extensions/initializer.rb:23:in `load_plugin'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/
initializer.rb:189:in `load_plugins'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/
initializer.rb:189:in `each'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/
initializer.rb:189:in `load_plugins'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/
initializer.rb:109:in `process'
         ... 29 levels...
        from /usr/local/lib/ruby/gems/1.8/gems/rails-1.2.4/lib/
commands/server.rb:39
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in `gem_original_require'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/
custom_require.rb:27:in `require'
        from script/server:3

Help please!

Fixed.

Don't know what happened but reinstalling ruby gems did the trick.
Running now on rails 1.2.4. Still have question about download
failure of Rails 1.2.6 gem.