Can't require active_support/dependencies in AS 5 beta 4

This is line 2 in spec_helper.rb:

require 'active_support/dependencies'

Here's the backtrace I get:

/home/rodrigo/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.beta4/lib/active_support/deprecation/proxy_wrappers.rb:124:in `initialize': undefined method `instance' for ActiveSupport::Deprecation:Class (NoMethodError)
Did you mean? instance_of?
         from /home/rodrigo/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.beta4/lib/active_support/deprecation/proxy_wrappers.rb:10:in `new'
         from /home/rodrigo/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.beta4/lib/active_support/deprecation/proxy_wrappers.rb:10:in `new'
         from /home/rodrigo/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.beta4/lib/active_support/core_ext/load_error.rb:30:in `<top (required)>'
         from /home/rodrigo/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.beta4/lib/active_support/dependencies.rb:12:in `require'
         from /home/rodrigo/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/activesupport-5.0.0.beta4/lib/active_support/dependencies.rb:12:in `<top (required)>'
         from /home/rodrigo/my-app/spec/spec_helper.rb:2:in `require'

Any ideas on what is causing that? Is this expected for AS 5?

Thanks in advance,
Rodrigo.

I created an issue here: https://github.com/rails/rails/issues/24818