Cannot get tlsmail working; Want Gmail as SMTP

This is killing me, folks. I have reviewed numerous examples and tried
two different approaches to try and use Gmail (Google Apps account) as
my application's SMTP. Every time, both on my slicehost server and local
dev machine (both Ubuntu Linux), my logs show no errors and I see a copy
of the mail in my logs. Yet I never received a test email. I've tried
both the action_mailer_tls plugin and the tlsmail gem. Both give the
same results. I prefer to get tlsmail working. Here are the tlsmail
settings, at the end of my environment.rb, that I'm using:

require 'tlsmail'

ActionMailer::Base.raise_delivery_errors = true
ActionMailer::Base.perform_deliveries = true
ActionMailer::Base.delivery_method = :smtp
ActionMailer::Base.smtp_settings = {
    :address => '',
    :port => 587,
    :tls => true,
    :domain => '[my google apps domain]',
    :authentication => :plain,
    :user_name => '[google apps login]',
    :password => '[password]'

With this setup I'm trying to use Gmail as my SMTP in both dev &
production mode with full logging.

I'm assuming there is a problem with my app connecting to the SMTP
server. How can I debug this? I'd like to trace the app's connection to
the SMTP server.

Is there a specific port I need open on my end to make the transaction

Any help with debugging would be greatly appreciated. Thank you.

Nevermind, it's working. I just wasn't looking in the right places.

Peter Frosta wrote:

Chris Stump wrote:

Nevermind, it's working. I just wasn't looking in the right places.


I think I have the same problem, could you describe what helped?

Nevermind, it's working now :slight_smile: