Bundler could not find compatible versions for gem "activesupport"

I tried to set up Searchlogic gem to my blog app and got an error:
Bundler could not find compatible versions for gem “activesupport”:
In Gemfile:
searchlogic (~> 2.5.17) x86-mingw32 depends on
activesupport (~> 2.3.12) x86-mingw32

rails (= 4.1.1) x86-mingw32 depends on
  activesupport (4.1.1)

``

Any solutions?

It means that searchlogic is only compatible with rails 2.3.x but that you’re using rails 4.1.1. Judging by the gem’s github page it’s not really being maintained - either find a fork that is maintained (and has been updated for newer versions of rails) or pick a different gem

Fred

You’ll need to find something besides Searchlogic, it’s no longer maintained. I’ve seen recommendations for Ransack:

https://github.com/activerecord-hackery/ransack

but haven’t used it myself.

–Matt Jones

I tried to set up Searchlogic gem to my blog app and got an error:
Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    searchlogic (~> 2.5.17) x86-mingw32 depends on
      activesupport (~> 2.3.12) x86-mingw32

    rails (= 4.1.1) x86-mingw32 depends on
      activesupport (4.1.1)

Any solutions?

You'll need to find something besides Searchlogic, it's no longer maintained. I've seen recommendations for Ransack:

https://github.com/activerecord-hackery/ransack

but haven't used it myself.

I've used ransack, but lately I've used scoped_search instead. Both work just fine, which one you use depends on how you want to construct your search forms.

Walter