Bundle Install

Hello All,

I am getting this error while running bundle install from console…

I tried to install libyaml & libtool & reinstalled all ruby.

But still I am getting the same error :-

Ruby - 1.9.3-p194

Jruby- 1.6.8

Rails - 3.2.6

Unfortunately, a fatal error has occurred. Please see the Bundler
troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!

/home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require’: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory - /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so (LoadError)

from /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/definition.rb:1:in `<top (required)>'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler.rb:144:in `definition'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/cli.rb:228:in `install'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/task.rb:27:in `run'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/invocation.rb:120:in `invoke_task'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor.rb:275:in `dispatch'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/vendor/thor/base.rb:408:in `start'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in `block in <top (required)>'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/lib/bundler/friendly_errors.rb:4:in `with_friendly_errors'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/gems/bundler-1.2.1/bin/bundle:14:in `<top (required)>'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `load'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/bundle:19:in `<main>'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `eval'

from /home/avinash/.rvm/gems/ruby-1.9.3-p194/bin/ruby_noexec_wrapper:14:in `<main>'

Any guide will be helpful…

Thanks

Hello All,

I am getting this error while running bundle install from console…

I tried to install libyaml & libtool & reinstalled all ruby.

But still I am getting the same error :-

Ruby - 1.9.3-p194

Jruby- 1.6.8

Rails - 3.2.6

Unfortunately, a fatal error has occurred. Please see the Bundler
troubleshooting documentation at http://bit.ly/bundler-issues. Thanks!

/home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in `require’: libcrypto.so.1.0.0: cannot open shared object file: No such file or directory - /home/avinash/.rvm/rubies/ruby-1.9.3-p194/lib/ruby/1.9.1/i686-linux/digest/sha1.so (LoadError)

hi! i recently upgraded to precise pangolin and i encountered issues like this one. usually, when you see errors like these, search

for the missing library and install the package that contains it. For this error, the package you want is libssl1.0.0 (in ubuntu). so install

that by sudo apt-get install libssl1.0.0 (in ubuntu).

I executed the command :- But I am getting this. I am in Ubuntu 10.10

Reading package lists… Done
Building dependency tree

Reading state information… Done

E: Unable to locate package libssl1.0.0

E: Couldn’t find any package by regex ‘libssl1.0.0’

I executed the command :- But I am getting this. I am in Ubuntu 10.10
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package libssl1.0.0
E: Couldn't find any package by regex 'libssl1.0.0'

Try
sudo apt-get install openssl libssl-dev

Colin

I executed the command :- But I am getting this. I am in Ubuntu 10.10
Reading package lists… Done
Building dependency tree

Reading state information… Done

E: Unable to locate package libssl1.0.0

E: Couldn’t find any package by regex ‘libssl1.0.0’

Have you tried installing other packages? like libssl-dev? see if that fixes it. If not, try to reinstall bundler and see

what specific packages you’re missing.

To add to what Colin said when I can't recognize a lib right off the
bat I do something like:

apt-cache search libssl |grep -- -dev
then pick the one that is right
apt-cache show libssl-dev will give you the version.

Though most of the time you will not have version issues with deep
system libs like that unless the library is mad outdated then
obviously you don't want it anyways.

I tried with that. It is installing.
But getting the same error while bundle install.

I tried with that. It is installing.
But getting the same error while bundle install.

Is rvm working ok? Does
rvm info
show sensible data? Have you added the line to .bashrc as indicated in
rvm notes

Colin

Yes, rvm is working fine.
version - 1.16.13
I have added in .bashrc file also .
But I don’t know why I am getting this error.

What is the output of ldconfig -p? You should see something like:

ldconfig -p |grep libssl
        libssl3.so (libc6) => /usr/lib/i386-linux-gnu/libssl3.so
        libssl.so.1.0.0 (libc6) => /lib/i386-linux-gnu/libssl.so.1.0.0
        libssl.so.0.9.8 (libc6) => /lib/i386-linux-gnu/libssl.so.0.9.8
        libssl.so.0.9.8 (libc6) => /usr/lib/i386-linux-gnu/libssl.so.0.9.8
        libssl.so (libc6) => /usr/lib/i386-linux-gnu/libssl.so

I uninstalled rvm, ruby, & gems everything…
Then I installed a fresh from start. It seems to be working…
Thanks all for your replies to help me out. :slight_smile: